Probleme mit externen Festplatten

Vor ein paar Tagen hatte ich ja schon einmal geschrieben, dass ich bei meiner neu gekauften externen Festplatte, nämlich der 1TB-Elements von Western Digital Probleme beim Kopieren von Fotos habe.

Da es natürlich nicht sein kann, dass auf einmal meine tollten Fotos kaputt sind, wollte ich der Sache auf den Grund gehen. Mir ist nämlich aufgefallen, dass inzwischen ein paar Bilder mehr defekt sind, obwohl ich mir sicher war, alle korrekt von den CF- und SD-Karten kopiert zu haben. Da es sich ausschließlich um Hochkant-Fotos handelt gehe ich davon aus, dass diese zunächst richtig kopiert wurden, aber dann beim Drehen und dem anschließenden Speichern kaputt gemacht wurden.

Fehler auch auf zweiter Festplatte

Um zu testen, ob vielleicht die Festplatte selbst einen Schlag hatte, habe ich eine identische genommen (hatte nämlich gleich zwei Stück davon bestellt) und diese dann mal komplett neu formatiert mit NTFS (ausgeliefert wird sie in FAT32), weil ich dachte, dass das Filesystem vielleicht besser dafür ist. Da ich die Platte sowieso nur hier an meinem Rechner verwende, dürfte das zu keinerlei Problemen führen.

Nach dem Formatieren, dass fast einen kompletten Tag und eine komplette Nacht dauerte, habe ich die Bilder draufkopiert und siehe da: auch hier traten die gleichen Fehler auf. Dass gleich zwei nagelneue Festplatten defekt sind, die Chance ist relativ gering, es muss also an etwas anderem liegen. Aber an was?

Weitere Versuche, das Problem einzugrenzen

Um überhaupt mal einen Ansatz zu haben, woran es liegen könnte, habe ich folgendes gemacht: meine CF-Karte mit knapp 500 Original-Fotos in den Kartenleser geschoben und die Bilder auf ALLE meine Festplatten kopiert, also auf zwei weitere externe anderen Typs und auf das Laufwerk C mit dem Resultat, dass auf allen per USB angeschlossenen externen Festplatten die Daten fehlerhaft waren. Lediglich auf die eingebaute Platte, quasi auf das Laufwerk C, wurde korrekt kopiert.

Das heißt für mich, von der Karte kann korrekt gelesen werden und die Daten kommen auch richtig auf dem Rechner an.

Als nächstes habe ich dann versucht, von Laufwerk C auf die externen Festplatten zu kopieren. Auch hier traten wieder die bekannten Fehler auf, auch wieder auf allen Platten. Definitiv kann ich also nicht korrekt auf eine USB-Platte kopieren.

Was ist zu tun?

Also… ich kann anscheinend nicht korrekt auf meine externen Festplatten kopieren. Woran könnte das liegen?

Die externen Festplatten (insgesamt vier Stück) hängen an einem 7-fach USB2.0-Hub, der wiederum an meinen PC angeschlossen ist. Alle Geräte, auch der Hub, haben eine eigene Stromversorgung, es ist also nichts bus-powered. Den Hub habe ich erst vor zwei Tagen angeschlossen, das Problem tauchte aber auch schon vorher auf, als als die Festplatten noch direkt an den Rechner angeschlossen waren, kann also nicht das Problem sein.

Jemand eine Idee, woran das liegt und was ich machen kann? Ich bin nämlich mit meinem Latein am Ende… 😕

Fehler beim Kopieren von Bildern

Da ich auf Anhieb nichts dazu gefunden habe, stelle ich hier mal die Frage ein, in der Hoffnung, es verirrt sich jemand hierher, der eine Antwort weiß.

Also, ich habe eine externe Festplatte, die über USB an meinen Windows-Vista-Rechner angeschlossen ist. Da hat sich mit der Zeit so einiges an Daten angesammelt, so dass nicht mehr viel drauf passt. Also habe ich nun eine neue externe Festplatte gekauft, ebenfalls per USB angeschlossen und einen großen Teil der Daten (insbesondere meine ganzen Digitalfotos) rüberkopiert.

Falsch kopierte Fotos

Beim Durchsehen ist mir nun aufgefallen, dass manche der kopierten Fotos fehlerhaft sind. Die kaputten Bilder werden zwar angezeigt, aber meist ist der letzte Teil des Fotos beschädigt, entweder komplett schwarz oder weiß oder man erkennt, was da ist, allerdings viel zu dunkel und etwas verschoben.

Hier zwei Beispiele, wie das dann aussieht:

Fehlerhaft kopiertes BildKaputtes Foto

Ich denke also, dass da ein paar Bits verschoben wurden, weil beim Kopieren der Daten irgendwelche Störungen auftraten, die die Fehlerkorrektur nicht ausbügeln konnte. Die kopierten Dateien sind zwar absolut gleich groß, wie auch die Originale, allerdings unterscheiden sie sich in der Prüfsumme. Das heißt, sie sind definitiv nicht 100% identisch.

Übrigens: Das gleiche Problem habe ich schon einige Male beim Kopieren von Daten von und auf einen USB-Stick festgestellt.

Was kann man dagegen tun?

Da meine Bilder für mich persönlich so ziemlich die heiligsten Daten sind, die ich auf meinem PC habe, möchte ich natürlich nicht, dass durch meine Kopier-Aktion meine tollen Bilder zerstört werden. Deshalb stellen sich mir nun folgende Fragen, bei denen ich euch bitten würde, sofern ihr eine Lösung habt, sie zu beantworten:

  • Wieso und weshalb tritt ein solcher Fehler beim Kopieren auf?
  • Wie kann ich -möglichst automatisiert- überprüfen, welche Bilder fehlerhaft kopiert wurden und diese ggf. auch gleich ersetzen?